Currently known issues

Important Announcements

Please find below important announcements relating to Educational Technologies at La Trobe, including known issues currently affecting users along with any available workarounds.

LMS (MOODLE) - The Learning Management System

LMS Moodle 3.9 Upgrade

The La Trobe University learning management system (LMS) will be upgraded from Moodle 3.5 to Moodle 3.9 on Saturday, 5 December, 2020.

The purpose of the upgrade is to ensure that the University is using a supported version of Moodle, which will bring a number of new features and improvements. There are also new enhancements based on feedback from the Colleges currently being investigated as part of the upgrade project.

Knowledge base articles and other support resources will be updated and created as the new LMS features and improvements are made available.

For more information about the latest updates please visit:

LMS Upgrade Project

 

Information Services System Requirements & Compatibility

See below the recommended browser, versions and operating system requirements for using the technologies. This will provide users with critical information for using the technologies and will enable them to have the best user experience possible.

LMS (MOODLE) - The Learning Management System

Application: LMS (MOODLE) - The Learning Management System

PlatformSystem and hardware requirements
WindowsWindows 10, Windows 8.1, Windows 7.
MacOS x 10.10 to latest
Supported BrowsersGoogle Chrome - minimum version 30.0
Firefox - minimum version 25.0
Safari - minimum version 6
Internet Explorer 9. Version 10 is required for drag and drop upload of content from outside the browser into Moodle.

LMS Admin (Manage My Subjects)

Application: LMS Admin (Manage My Subjects)

PlatformSystem and hardware requirements
WindowsWindows 10, Windows 8.1, Windows 7.
MacOS X 10.10 and above
Supported BrowsersGoogle Chrome - version 65 (64 bit)
Firefox - version 52 (64 bit)
Safari - 11
Internet Explorer 11

Echo360

Application: Echo360

PlatformSystem and hardware requirements
WindowsWindows 10, Windows 8.1, Windows 7.
MacOS X 10.10 - OS X 10.12
Supported BrowsersGoogle Chrome - most recent version
Firefox - most recent version
Safari - most recent version
Edge - most recent version (Windows 10 native browser)
Internet Explorer 11 is not supported

PebblePad

Application: PebblePad

PlatformSystem and hardware requirements
WindowsWindows 10, Windows 8.1, Windows 7.
MacOS X 10.10 and above
Mobileminimum mobile operating systems supported:
- iOS 9
- Android 5.1.1
- Blackberry OS 10.3.0
- Windows 10
Supported BrowsersGoogle Chrome - most recent version 59
Firefox - most recent version 53
Safari - minimum version 9
Internet Explorer 11

Turnitin

Application: Turnitin

PlatformSystem and hardware requirements
WindowsWindows 10, Windows 8, Windows 7.
MacOS X 10.7 and above
Supported BrowsersGoogle Chrome - minimum version 30.0
Firefox - minimum version 25.0
Safari - minimum version 6
Internet Explorer 9

Zoom (for Staff)

Application: Zoom for Staff

PlatformSystem and hardware requirements
WindowsWindows 10, Windows 8.1, Windows 7.
MacOS X 10.7 or later
Supported BrowsersGoogle Chrome 
Firefox 
Safari5+
Internet Explorer 7
 

Who can I go to if I have any questions?

Students should be directed to Student IT Support

If you require support in the use of the LMS or other educational technologies, please contact ASK EDTECH.

More support information is available on our Support and Contacts page.